summaryrefslogtreecommitdiffstats
path: root/tdeioslave/smtp/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:02:02 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:02:02 -0600
commitde7e5867a65e0a46f1388e3e50bc7eeddd1aecbf (patch)
treedbb3152c372f8620f9290137d461f3d9f9eba1cb /tdeioslave/smtp/Makefile.am
parent936d3cec490c13f2c5f7dd14f5e364fddaa6da71 (diff)
downloadtdebase-de7e5867a65e0a46f1388e3e50bc7eeddd1aecbf.tar.gz
tdebase-de7e5867a65e0a46f1388e3e50bc7eeddd1aecbf.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/smtp/Makefile.am')
-rw-r--r--tdeioslave/smtp/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/tdeioslave/smtp/Makefile.am b/tdeioslave/smtp/Makefile.am
new file mode 100644
index 000000000..7808a24db
--- /dev/null
+++ b/tdeioslave/smtp/Makefile.am
@@ -0,0 +1,37 @@
+
+INCLUDES= -I$(srcdir)/../.. -I$(srcdir)/.. $(SSL_INCLUDES) $(all_includes)
+
+kde_module_LTLIBRARIES = kio_smtp.la
+
+kio_smtp_la_SOURCES = smtp.cc request.cc response.cc capabilities.cc command.cc transactionstate.cc
+kio_smtp_la_LIBADD = $(LIB_KIO) $(SASL2_LIBS)
+kio_smtp_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+noinst_HEADERS = smtp.h request.h response.h capabilities.h command.h transactionstate.h
+
+kdelnk_DATA = smtp.protocol smtps.protocol
+kdelnkdir = $(kde_servicesdir)
+
+TESTS = test_headergeneration test_responseparser test_commands
+
+check_PROGRAMS = $(TESTS) interactivesmtpserver
+
+test_headergeneration_SOURCES = test_headergeneration.cc
+test_headergeneration_LDADD = $(LIB_TDECORE)
+test_headergeneration_LDFLAGS = $(all_libraries)
+
+test_responseparser_SOURCES = test_responseparser.cc
+test_responseparser_LDADD = $(LIB_TDECORE)
+test_responseparser_LDFLAGS = $(all_libraries)
+
+test_commands_SOURCES = test_commands.cc
+test_commands_LDADD = $(kio_smtp_la_LIBADD)
+test_commands_LDFLAGS = $(all_libraries)
+
+interactivesmtpserver_SOURCES = interactivesmtpserver.cc
+interactivesmtpserver_LDADD = $(LIB_QT)
+interactivesmtpserver_LDFLAGS = $(all_libraries)
+interactivesmtpserver_METASOURCES = AUTO
+
+messages:
+ $(XGETTEXT) *.cc -o $(podir)/tdeio_smtp.pot