summaryrefslogtreecommitdiffstats
path: root/tdeioslave/trash/CMakeLists.txt
diff options
context:
space:
mode:
authorEmanoil Kotsev <deloptes@gmail.com>2016-10-12 15:20:02 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2016-10-12 15:20:02 +0900
commitee3091bc41f5cae8be2ba5f8335e0b866edb4711 (patch)
tree8ffc7ba391bb968e9de33674fa6caf5e9166e5eb /tdeioslave/trash/CMakeLists.txt
parent443c910570647f415838e65a1b8add30b00b7dbb (diff)
downloadtdebase-ee3091bc41f5cae8be2ba5f8335e0b866edb4711.tar.gz
tdebase-ee3091bc41f5cae8be2ba5f8335e0b866edb4711.zip
Added trash limit configuration option
This work is based on original patch created by Tobias Koenig <tokoe@kde.org> for KDE 3.5.9 and later added to KDE 4.2, and available under GPL version 2 License, or any later version. See also http://tokoe-kde.blogspot.com/2008/08/size-limits-for-trash.html This relates to bug 1923. Signed-off-by: Emanoil Kotsev <deloptes@gmail.com> Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'tdeioslave/trash/CMakeLists.txt')
-rw-r--r--tdeioslave/trash/CMakeLists.txt19
1 files changed, 17 insertions, 2 deletions
diff --git a/tdeioslave/trash/CMakeLists.txt b/tdeioslave/trash/CMakeLists.txt
index 1569d07ca..1082b57af 100644
--- a/tdeioslave/trash/CMakeLists.txt
+++ b/tdeioslave/trash/CMakeLists.txt
@@ -25,7 +25,7 @@ link_directories(
##### other data ################################
-install( FILES trash.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES ktrashpropsdlgplugin.desktop trash.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
##### trashcommon (static) ######################
@@ -33,7 +33,7 @@ install( FILES trash.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
set( target trashcommon )
tde_add_library( ${target} STATIC_PIC AUTOMOC
- SOURCES trashimpl.cpp
+ SOURCES trashimpl.cpp discspaceutil.cpp
)
@@ -47,6 +47,15 @@ tde_add_kpart( ${target} AUTOMOC
DESTINATION ${PLUGIN_INSTALL_DIR}
)
+##### ktrashpropsdlgplugin (module) ########################
+
+set( target ktrashpropsdlgplugin )
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES ktrashpropsdlgplugin.cpp
+ LINK trashcommon-static tdeio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
##### ktrash (executable) #######################
@@ -57,3 +66,9 @@ tde_add_executable( ${target}
LINK tdeio-shared
DESTINATION ${BIN_INSTALL_DIR}
)
+
+##### testtrash (executable) #######################
+tde_add_executable( testtrash
+ SOURCES testtrash.cpp AUTOMOC
+ LINK trashcommon-static tdeio-shared
+)