summaryrefslogtreecommitdiffstats
path: root/kjsembed/plugin/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit90825e2392b2d70e43c7a25b8a3752299a933894 (patch)
treee33aa27f02b74604afbfd0ea4f1cfca8833d882a /kjsembed/plugin/Makefile.am
downloadtdebindings-90825e2392b2d70e43c7a25b8a3752299a933894.tar.gz
tdebindings-90825e2392b2d70e43c7a25b8a3752299a933894.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebindings@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kjsembed/plugin/Makefile.am')
-rw-r--r--kjsembed/plugin/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/kjsembed/plugin/Makefile.am b/kjsembed/plugin/Makefile.am
new file mode 100644
index 00000000..9ec99770
--- /dev/null
+++ b/kjsembed/plugin/Makefile.am
@@ -0,0 +1,20 @@
+# -*- makefile -*-
+
+# Make sure the include path includes Qt's uilib
+INCLUDES= -I$(QTDIR)/tools/designer/uilib -I$(srcdir)/.. -I.. -I$(top_srcdir) $(all_includes)
+
+INCLUDES += -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST
+
+kde_module_LTLIBRARIES = libjsconsoleplugin.la
+
+METASOURCES = AUTO
+
+libjsconsoleplugin_la_SOURCES = jsconsoleplugin.cpp
+libjsconsoleplugin_la_LIBADD = $(LIB_KPARTS) ../libkjsembed.la
+libjsconsoleplugin_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries) $(KDE_RPATH)
+
+#pluginsdir = $(kde_datadir)/konqueror/kpartplugins
+#plugins_DATA = plugin_jsconsole.rc
+
+
+