summaryrefslogtreecommitdiffstats
path: root/kjsembed/tdescript/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:00 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:00 -0600
commit2d84c9d3ad0aaea0620658024537d54e6a7939f4 (patch)
tree35675532f42e78dbfcd56c6b344e1f0e79013a2e /kjsembed/tdescript/Makefile.am
parent980972d200e109a643e5a10037d7f9fcf02382ed (diff)
downloadtdebindings-2d84c9d3ad0aaea0620658024537d54e6a7939f4.tar.gz
tdebindings-2d84c9d3ad0aaea0620658024537d54e6a7939f4.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'kjsembed/tdescript/Makefile.am')
-rw-r--r--kjsembed/tdescript/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kjsembed/tdescript/Makefile.am b/kjsembed/tdescript/Makefile.am
new file mode 100644
index 00000000..adcf52d4
--- /dev/null
+++ b/kjsembed/tdescript/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES = -I$(srcdir) -I$(top_srcdir) $(all_includes)
+
+kde_module_LTLIBRARIES = libjavascript.la
+
+libjavascript_la_SOURCES = javascript.cpp
+libjavascript_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) -lDCOP -ltdecore -ltdeui $(LIB_QT) -lkjs -ltdefx -no-undefined -avoid-version
+libjavascript_la_LIBADD = -ltdescript ../libkjsembed.la
+
+
+METASOURCES = AUTO
+
+servicetypedir = $(kde_servicesdir)
+servicetype_DATA = javascript.desktop
+
+katescriptsdir = $(kde_datadir)/kate/scripts
+katescripts_DATA = swaptabs.desktop swaptabs.ui
+katescripts_SCRIPTS = swaptabs.js