summaryrefslogtreecommitdiffstats
path: root/korundum/rubylib/rbkconfig_compiler/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit90825e2392b2d70e43c7a25b8a3752299a933894 (patch)
treee33aa27f02b74604afbfd0ea4f1cfca8833d882a /korundum/rubylib/rbkconfig_compiler/Makefile.am
downloadtdebindings-90825e2392b2d70e43c7a25b8a3752299a933894.tar.gz
tdebindings-90825e2392b2d70e43c7a25b8a3752299a933894.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebindings@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'korundum/rubylib/rbkconfig_compiler/Makefile.am')
-rw-r--r--korundum/rubylib/rbkconfig_compiler/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/korundum/rubylib/rbkconfig_compiler/Makefile.am b/korundum/rubylib/rbkconfig_compiler/Makefile.am
new file mode 100644
index 00000000..492c6882
--- /dev/null
+++ b/korundum/rubylib/rbkconfig_compiler/Makefile.am
@@ -0,0 +1,28 @@
+SUBDIRS = . tests
+
+RBUIC=rbuic
+
+%.rb: %.ui
+ $(RBUIC) -tr ${UIC_TR} -kde $*.ui -o $@
+
+exampleprefs_base.rb: $(srcdir)/example.kcfg rbkconfig_compiler $(srcdir)/exampleprefs_base.kcfgc
+ ./rbkconfig_compiler $(srcdir)/example.kcfg $(srcdir)/exampleprefs_base.kcfgc
+
+AM_CPPFLAGS = -I$(top_srcdir)/kdecore -I$(top_srcdir) $(all_includes)
+
+bin_PROGRAMS = rbkconfig_compiler
+
+rbkconfig_compiler_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+rbkconfig_compiler_LDADD = $(LIB_KDECORE)
+rbkconfig_compiler_SOURCES = rbkconfig_compiler.cpp
+
+METASOURCES = AUTO
+
+TESTFILES = test1.kcfg test2.kcfg test3.kcfg test4.kcfg test5.kcfg
+
+check-local:
+ for i in $(TESTFILES); \
+ do xmllint --noout --schema $(srcdir)/kcfg.xsd $(srcdir)/tests/$$i; \
+ perl $(top_srcdir)/korundum/rubylib/rbkconfig_compiler/checkkcfg.pl \
+ $(top_srcdir)/korundum/rubylib/rbkconfig_compiler/tests/$$i; done
+