summaryrefslogtreecommitdiffstats
path: root/korundum/rubylib/rbtdeconfig_compiler/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:02:53 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:02:53 -0600
commit545706afdcf29b8f584e78275452cca715e284db (patch)
treefdbfaa34f2d633372ba4ab3e46d22cf10f38b40b /korundum/rubylib/rbtdeconfig_compiler/Makefile.am
parent9d4971a2ffb5be9c6fc1b6d6bc74020c37fb2169 (diff)
downloadtdebindings-545706afdcf29b8f584e78275452cca715e284db.tar.gz
tdebindings-545706afdcf29b8f584e78275452cca715e284db.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'korundum/rubylib/rbtdeconfig_compiler/Makefile.am')
-rw-r--r--korundum/rubylib/rbtdeconfig_compiler/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/korundum/rubylib/rbtdeconfig_compiler/Makefile.am b/korundum/rubylib/rbtdeconfig_compiler/Makefile.am
new file mode 100644
index 00000000..8931f18a
--- /dev/null
+++ b/korundum/rubylib/rbtdeconfig_compiler/Makefile.am
@@ -0,0 +1,28 @@
+SUBDIRS = . tests
+
+RBUIC=rbuic
+
+.ui.rb:
+ $(RBUIC) -tr ${UIC_TR} -kde $*.ui -o $@
+
+exampleprefs_base.rb: $(srcdir)/example.kcfg rbtdeconfig_compiler $(srcdir)/exampleprefs_base.kcfgc
+ ./rbtdeconfig_compiler $(srcdir)/example.kcfg $(srcdir)/exampleprefs_base.kcfgc
+
+AM_CPPFLAGS = -I$(top_srcdir)/tdecore -I$(top_srcdir) $(all_includes)
+
+bin_PROGRAMS = rbtdeconfig_compiler
+
+rbtdeconfig_compiler_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
+rbtdeconfig_compiler_LDADD = $(LIB_TDECORE)
+rbtdeconfig_compiler_SOURCES = rbtdeconfig_compiler.cpp
+
+METASOURCES = AUTO
+
+TESTFILES = test1.kcfg test2.kcfg test3.kcfg test4.kcfg test5.kcfg
+
+check-local:
+ for i in $(TESTFILES); \
+ do xmllint --noout --schema $(srcdir)/kcfg.xsd $(srcdir)/tests/$$i; \
+ perl $(top_srcdir)/korundum/rubylib/rbtdeconfig_compiler/checkkcfg.pl \
+ $(top_srcdir)/korundum/rubylib/rbtdeconfig_compiler/tests/$$i; done
+