summaryrefslogtreecommitdiffstats
path: root/smoke/qt/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit90825e2392b2d70e43c7a25b8a3752299a933894 (patch)
treee33aa27f02b74604afbfd0ea4f1cfca8833d882a /smoke/qt/Makefile.am
downloadtdebindings-90825e2392b2d70e43c7a25b8a3752299a933894.tar.gz
tdebindings-90825e2392b2d70e43c7a25b8a3752299a933894.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdebindings@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'smoke/qt/Makefile.am')
-rw-r--r--smoke/qt/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/smoke/qt/Makefile.am b/smoke/qt/Makefile.am
new file mode 100644
index 00000000..343f7704
--- /dev/null
+++ b/smoke/qt/Makefile.am
@@ -0,0 +1,24 @@
+lib_LTLIBRARIES = libsmokeqt.la
+
+# set the include path for X, qt and KDE
+INCLUDES = -I$(srcdir)/.. $(all_includes)
+
+EXTRA_DIST=generate.pl.in qtguess.pl.in qt_smoke.h Makefile.am
+
+# the library search path.
+libsmokeqt_la_LDFLAGS = -version-info 3:2:2 -no-undefined $(all_libraries) $(GLINC)
+
+# the libraries to link against.
+libsmokeqt_la_LIBADD = $(LIB_QT) $(GLLIB) $(LIBQSCINTILLA)
+
+x_sources = x_1.cpp x_2.cpp x_3.cpp x_4.cpp x_5.cpp x_6.cpp x_7.cpp \
+ x_8.cpp x_9.cpp x_10.cpp x_11.cpp x_12.cpp x_13.cpp x_14.cpp x_15.cpp \
+ x_16.cpp x_17.cpp x_18.cpp x_19.cpp x_20.cpp
+
+# which sources should be compiled for perlqtkde
+libsmokeqt_la_SOURCES = $(x_sources) smokedata.cpp
+
+$(x_sources) smokedata.cpp:
+ perl generate.pl
+
+CLEANFILES = $(libsmokeqt_la_SOURCES)