summaryrefslogtreecommitdiffstats
path: root/qtsharp/src/bindings/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'qtsharp/src/bindings/Makefile.am')
-rw-r--r--qtsharp/src/bindings/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/qtsharp/src/bindings/Makefile.am b/qtsharp/src/bindings/Makefile.am
new file mode 100644
index 00000000..9732e2ec
--- /dev/null
+++ b/qtsharp/src/bindings/Makefile.am
@@ -0,0 +1,23 @@
+all: Qt.dll
+
+QWidget.cs:
+ $(CLI) ../generator/generator.exe -f ../api/qt.xml -d .
+
+Qt.dll: QWidget.cs $(wildcard *.cs) $(wildcard static/*.cs)
+ cp static/*.cs .
+ csant -D$(CSC_NAME)=$(CSC) -C $(CSC_NAME)
+
+clean:
+ -rm Qt.dll
+
+distclean: clean
+ -rm *.cs
+
+install:
+ if ! test -d $(DESTDIR)$(libdir); then $(INSTALL) -d -m 0755 $(DESTDIR)$(libdir); fi
+ $(INSTALL) -m 0644 Qt.dll $(DESTDIR)$(libdir)
+
+uninstall:
+ rm -rf $(libdir)/Qt.dll
+
+.PHONY: all clean distclean install uninstall