summaryrefslogtreecommitdiffstats
path: root/qtsharp/src/examples/samples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'qtsharp/src/examples/samples/Makefile.am')
-rw-r--r--qtsharp/src/examples/samples/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/qtsharp/src/examples/samples/Makefile.am b/qtsharp/src/examples/samples/Makefile.am
new file mode 100644
index 00000000..eae1d7cc
--- /dev/null
+++ b/qtsharp/src/examples/samples/Makefile.am
@@ -0,0 +1,24 @@
+all:
+ csant -D$(CSC_NAME)=$(CSC) -C $(CSC_NAME)
+ chmod 0755 *.exe
+
+clean:
+ rm -rf *.exe
+
+distclean: clean
+
+install:
+ mkdir -p $(DESTDIR)$(datadir)/doc/qtcsharp/samples
+ cat display.cs | gzip -9c > $(DESTDIR)$(datadir)/doc/qtcsharp/samples/display.cs.gz
+ cat eventhandling.cs | gzip -9c > $(DESTDIR)$(datadir)/doc/qtcsharp/samples/eventhandling.cs.gz
+ cat hello.cs | gzip -9c > $(DESTDIR)$(datadir)/doc/qtcsharp/samples/hello.cs.gz
+ cat scribblewindow.cs | gzip -9c > $(DESTDIR)$(datadir)/doc/qtcsharp/samples/scribblewindow.cs.gz
+ cat mandelbrot.cs | gzip -9c > $(DESTDIR)$(datadir)/doc/qtcsharp/samples/mandelbrot.cs.gz
+ cat quantumfractals.cs | gzip -9c > $(DESTDIR)$(datadir)/doc/qtcsharp/samples/quantumfractals.cs.gz
+ cat mandelbrot2.cs | gzip -9c > $(DESTDIR)$(datadir)/doc/qtcsharp/samples/mandelbrot2.cs.gz
+
+uninstall:
+ rm -rf $(datadir)/doc/qtcsharp/samples/*.cs.gz
+ rm -rf $(datadir)/doc/qtcsharp/samples/*.cs
+
+.PHONY: all clean distclean install