summaryrefslogtreecommitdiffstats
path: root/smoke/tde/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'smoke/tde/Makefile.am')
-rw-r--r--smoke/tde/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/smoke/tde/Makefile.am b/smoke/tde/Makefile.am
new file mode 100644
index 00000000..9c85ccc1
--- /dev/null
+++ b/smoke/tde/Makefile.am
@@ -0,0 +1,24 @@
+lib_LTLIBRARIES = libsmoketde.la
+
+# set the include path for X, qt and KDE
+INCLUDES = -I$(srcdir)/.. $(all_includes)
+
+EXTRA_DIST=generate.pl.in qtguess.pl.in qt_smoke.h Makefile.am
+
+# the library search path.
+libsmoketde_la_LDFLAGS = -version-info 3:2:2 -no-undefined $(all_libraries) $(GLINC) $(KDE_RPATH)
+
+# the libraries to link against.
+libsmoketde_la_LIBADD = $(LIB_TDEHTML) -lkjs -lfontconfig $(LIB_KMDI) $(LIB_KNS) $(LIB_KSPELL) $(LIB_KUTILS) $(LIB_TDEPRINT) $(GLLIB) $(LIB_QT) $(LIB_TDEUI) $(LIB_TDECORE) $(LIB_KIO) $(LIB_KPARTS) -lDCOP -ltdefx
+
+x_sources = x_1.cpp x_2.cpp x_3.cpp x_4.cpp x_5.cpp x_6.cpp x_7.cpp \
+ x_8.cpp x_9.cpp x_10.cpp x_11.cpp x_12.cpp x_13.cpp x_14.cpp x_15.cpp \
+ x_16.cpp x_17.cpp x_18.cpp x_19.cpp x_20.cpp
+
+# which sources should be compiled for perlqtkde
+libsmoketde_la_SOURCES = $(x_sources) smokedata.cpp
+
+$(x_sources) smokedata.cpp:
+ perl generate.pl
+
+CLEANFILES = $(libsmoketde_la_SOURCES)