summaryrefslogtreecommitdiffstats
path: root/kig/tdefile/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-27 03:12:08 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-28 17:51:29 +0200
commita084db175509b58e57a81d50b1688709f19758bf (patch)
tree0fdf4c3292e92897faf783775d038f7bf8ca21d2 /kig/tdefile/CMakeLists.txt
parent5255f3b93733410203e467b9442dca1948ffa361 (diff)
downloadtdeedu-a084db175509b58e57a81d50b1688709f19758bf.tar.gz
tdeedu-a084db175509b58e57a81d50b1688709f19758bf.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kig/tdefile/CMakeLists.txt')
-rw-r--r--kig/tdefile/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/kig/tdefile/CMakeLists.txt b/kig/tdefile/CMakeLists.txt
index ec7241ca..9d4ad579 100644
--- a/kig/tdefile/CMakeLists.txt
+++ b/kig/tdefile/CMakeLists.txt
@@ -44,7 +44,10 @@ tde_add_kpart( tdefile_kig AUTOMOC
##### other data
-install(
- FILES tdefile_drgeo.desktop tdefile_kig.desktop
+foreach( _tdefile tdefile_drgeo.desktop tdefile_kig.desktop )
+ tde_create_translated_desktop(
+ SOURCE ${_tdefile}
DESTINATION ${SERVICES_INSTALL_DIR}
-)
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kig-tdefile
+ )
+endforeach()