summaryrefslogtreecommitdiffstats
path: root/ktouch/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-06-27 16:35:25 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-06-27 16:35:25 +0200
commitd4a1613e9f119ae68c695ab60f8d9856d1a54a52 (patch)
tree6de888ef76667e28c81832dc104c19b158859b9b /ktouch/CMakeLists.txt
parent9fb4e1ccde0b89b413bfdc8ae62f8178ecad5483 (diff)
downloadtdeedu-d4a1613e9f119ae68c695ab60f8d9856d1a54a52.tar.gz
tdeedu-d4a1613e9f119ae68c695ab60f8d9856d1a54a52.zip
Conversion to the cmake building system.
Add includes to UI files to resolve FTBFS. Signed-off-by: gregory guy <g-gregory@gmx.fr> Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ktouch/CMakeLists.txt')
-rw-r--r--ktouch/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/ktouch/CMakeLists.txt b/ktouch/CMakeLists.txt
new file mode 100644
index 00000000..0c1ecf7d
--- /dev/null
+++ b/ktouch/CMakeLists.txt
@@ -0,0 +1,15 @@
+add_subdirectory( src )
+add_subdirectory( keyboards )
+add_subdirectory( training )
+add_subdirectory( sounds )
+add_subdirectory( graphics )
+add_subdirectory( icons )
+#add_subdirectory( extras )
+
+
+##### other data
+
+install(
+ FILES ktouch.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)