summaryrefslogtreecommitdiffstats
path: root/kgeography/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kgeography/src/CMakeLists.txt')
-rw-r--r--kgeography/src/CMakeLists.txt63
1 files changed, 63 insertions, 0 deletions
diff --git a/kgeography/src/CMakeLists.txt b/kgeography/src/CMakeLists.txt
new file mode 100644
index 00000000..e1d0b88d
--- /dev/null
+++ b/kgeography/src/CMakeLists.txt
@@ -0,0 +1,63 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### kgeography (executable)
+
+tde_add_executable( kgeography AUTOMOC
+
+ SOURCES
+ main.cpp
+ mapwidget.cpp
+ division.cpp
+ map.cpp
+ mapparser.cpp
+ kgeography.cpp
+ mapchooser.cpp
+ mypopup.cpp
+ popupmanager.cpp
+ flagdivisionasker.cpp
+ askwidget.cpp
+ mapasker.cpp
+ capitaldivisionasker.cpp
+ divisioncapitalasker.cpp
+ boxasker.cpp
+ divisionflagasker.cpp
+ answer.cpp
+ answersdialog.cpp
+ settings.kcfgc
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES kgeographyui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kgeography
+)
+
+install(
+ FILES kgeography.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+
+install(
+ FILES kgeography.kcfg
+ DESTINATION ${KCFG_INSTALL_DIR}
+)