summaryrefslogtreecommitdiffstats
path: root/libtdeedu/tdeeduui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libtdeedu/tdeeduui/CMakeLists.txt')
-rw-r--r--libtdeedu/tdeeduui/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/libtdeedu/tdeeduui/CMakeLists.txt b/libtdeedu/tdeeduui/CMakeLists.txt
new file mode 100644
index 00000000..ae095223
--- /dev/null
+++ b/libtdeedu/tdeeduui/CMakeLists.txt
@@ -0,0 +1,42 @@
+add_subdirectory( tests )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### tdeeduui (shared)
+
+tde_add_library( tdeeduui SHARED AUTOMOC
+
+ SOURCES
+ kedusimpleentrydlgForm.ui
+ kedusimpleentrydlg.cpp
+ tdeeduglossary.cpp
+ LINK
+ tdecore-shared
+ tdeio-shared
+ tdeui-shared
+ tdehtml-shared
+
+ VERSION 3.0.5
+
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES tdeeduglossary.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/libtdeedu
+)