summaryrefslogtreecommitdiffstats
path: root/kbounce/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2016-02-25 06:23:55 +0300
committerSlávek Banko <slavek.banko@axis.cz>2016-03-14 23:04:06 +0100
commitc70db62d3671e524d23ac974d296eb218159b000 (patch)
tree08d8ed5d0c7c170a7940bcbb80989b99ead98447 /kbounce/CMakeLists.txt
parent133cc7035dbdcaf812d8370f729530fa60547f92 (diff)
downloadtdegames-c70db62d3671e524d23ac974d296eb218159b000.tar.gz
tdegames-c70db62d3671e524d23ac974d296eb218159b000.zip
Initial cmake conversion
Diffstat (limited to 'kbounce/CMakeLists.txt')
-rw-r--r--kbounce/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/kbounce/CMakeLists.txt b/kbounce/CMakeLists.txt
new file mode 100644
index 00000000..da633954
--- /dev/null
+++ b/kbounce/CMakeLists.txt
@@ -0,0 +1,53 @@
+#################################################
+#
+# (C) 2016 Alexander Golubev
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( pics )
+add_subdirectory( sounds )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${CMAKE_SOURCE_DIR}/libtdegames/highscore
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ARTS_LIBRARY_DIRS}
+)
+
+
+if( WITH_ARTS )
+ set( ARTS_LIBRARIES artskde-shared )
+endif( WITH_ARTS )
+
+
+##### kbounce (executable) ######################
+
+tde_add_executable( kbounce AUTOMOC
+ SOURCES main.cpp kbounce.cpp game.cpp highscores.cpp
+ LINK tdecore-shared tdeui-shared tdegames-shared ${ARTS_LIBRARIES}
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES kbounceui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kbounce
+)
+
+install( FILES kbounce.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)