summaryrefslogtreecommitdiffstats
path: root/kpat/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2016-02-25 06:23:55 +0300
committerSlávek Banko <slavek.banko@axis.cz>2016-03-14 23:04:06 +0100
commitc70db62d3671e524d23ac974d296eb218159b000 (patch)
tree08d8ed5d0c7c170a7940bcbb80989b99ead98447 /kpat/CMakeLists.txt
parent133cc7035dbdcaf812d8370f729530fa60547f92 (diff)
downloadtdegames-c70db62d3671e524d23ac974d296eb218159b000.tar.gz
tdegames-c70db62d3671e524d23ac974d296eb218159b000.zip
Initial cmake conversion
Diffstat (limited to 'kpat/CMakeLists.txt')
-rw-r--r--kpat/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/kpat/CMakeLists.txt b/kpat/CMakeLists.txt
new file mode 100644
index 00000000..e1399487
--- /dev/null
+++ b/kpat/CMakeLists.txt
@@ -0,0 +1,54 @@
+#################################################
+#
+# (C) 2016 Alexander Golubev
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( icons )
+add_subdirectory( freecell-solver )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kpat (executable) #########################
+
+tde_add_executable( kpat AUTOMOC
+ SOURCES main.cpp cardmaps.cpp card.cpp dealer.cpp pwidget.cpp pile.cpp
+ deck.cpp pile_algorithms.cpp kings.cpp freecell.cpp klondike.cpp simon.cpp
+ grandf.cpp mod3.cpp idiot.cpp napoleon.cpp computation.cpp gypsy.cpp
+ fortyeight.cpp yukon.cpp clock.cpp golf.cpp spider.cpp gamestatsimpl.cpp
+ gamestats.ui
+ LINK tdecore-shared tdeui-shared tdeio-shared tdegames-shared fcs-static
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES green.png
+ DESTINATION ${DATA_INSTALL_DIR}/kpat/backgrounds
+)
+
+install( FILES kpatui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kpat
+)
+
+install( FILES kpat.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)