summaryrefslogtreecommitdiffstats
path: root/kspaceduel/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitc90c389a8a8d9d8661e9772ec4144c5cf2039f23 (patch)
tree6d8391395bce9eaea4ad78958617edb20c6a7573 /kspaceduel/Makefile.am
downloadtdegames-c90c389a8a8d9d8661e9772ec4144c5cf2039f23.tar.gz
tdegames-c90c389a8a8d9d8661e9772ec4144c5cf2039f23.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegames@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kspaceduel/Makefile.am')
-rw-r--r--kspaceduel/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/kspaceduel/Makefile.am b/kspaceduel/Makefile.am
new file mode 100644
index 00000000..00bdbe76
--- /dev/null
+++ b/kspaceduel/Makefile.am
@@ -0,0 +1,36 @@
+INCLUDES= -I$(top_srcdir)/libkdegames $(all_includes)
+
+SUBDIRS = sprites pics
+
+# you can add here more. This one gets installed
+bin_PROGRAMS = kspaceduel
+
+# Which sources should be compiled for kspaceduel.
+kspaceduel_SOURCES = general.ui mathroutines.cpp topwidget.cpp \
+ playerinfo.cpp sprites.cpp mainview.cpp dialogs.cpp ai.cpp \
+ main.cpp options.kcfgc
+
+kspaceduel_METASOURCES = AUTO
+EXTRA_DIST = kspaceduel.desktop kspaceduel.xpm mini-kspaceduel.xpm
+
+kspaceduel_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+kspaceduel_LDADD = $(LIB_KDEGAMES)
+kspaceduel_DEPENDENCIES = $(LIB_KDEGAMES_DEP)
+
+# this option you can leave out. Just, if you use "make dist", you need it
+noinst_HEADERS = mathroutines.h topwidget.h playerinfo.h \
+ sprites.h dialogs.h mainview.h defines.h ai.h structs.h \
+ version.h
+
+DISTCLEANFILES = $(kspaceduel_METASOURCES)
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kspaceduel.pot
+
+KDE_ICON = kspaceduel
+
+xdg_apps_DATA = kspaceduel.desktop
+kde_kcfg_DATA = kspaceduel.kcfg
+
+rcdir=$(kde_datadir)/kspaceduel
+rc_DATA = kspaceduelui.rc