summaryrefslogtreecommitdiffstats
path: root/twin4/grafix/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-07 21:50:33 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-07 21:50:33 -0600
commita1966f0f2ceedaa54544b76dd22aa80896d7b4b3 (patch)
tree889048788b625253a81ccfe4b16c1d7cd3c8deb6 /twin4/grafix/Makefile.am
parentcbf01c9f46601b83b66e9d6a78b3a71753aaaf11 (diff)
downloadtdegames-a1966f0f2ceedaa54544b76dd22aa80896d7b4b3.tar.gz
tdegames-a1966f0f2ceedaa54544b76dd22aa80896d7b4b3.zip
Rename kwin to twin (Part 2 of 2)
Diffstat (limited to 'twin4/grafix/Makefile.am')
-rw-r--r--twin4/grafix/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/twin4/grafix/Makefile.am b/twin4/grafix/Makefile.am
new file mode 100644
index 00000000..70c3bfeb
--- /dev/null
+++ b/twin4/grafix/Makefile.am
@@ -0,0 +1,22 @@
+GRAFIXDIRS = default
+
+grafixdir = $(kde_datadir)/twin4/grafix
+
+uninstall-local:
+ rm -rf $(DESTDIR)$(grafixdir)
+
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(grafixdir)
+ for i in $(GRAFIXDIRS); do \
+ if test -d $(DESTDIR)$(grafixdir)/$$i; then \
+ echo "refreshing and removing $$i" ;\
+ rm -rf $(DESTDIR)$(grafixdir)/$$i;\
+ fi ;\
+ echo "installing $$i" ;\
+ if test ! -d $(DESTDIR)$(grafixdir)/$$i; then \
+ cp -r $(srcdir)/$$i $(DESTDIR)$(grafixdir)/$$i ;\
+ rm -rf $(DESTDIR)$(grafixdir)/$$i/CVS ;\
+ rm -rf $(DESTDIR)$(grafixdir)/$$i/.svn ;\
+ fi ;\
+ done
+