summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/dependencies/poppler-tqt/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-06-19 19:11:56 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-06-19 19:11:56 +0000
commit546886fdccdc2bc112e6f9eaf99a34aac1d2234e (patch)
treed017156784059256a2fc6bef83d31590cdcaf93a /kfile-plugins/dependencies/poppler-tqt/Makefile.am
parente69e8b1d09fb579316595b4e6a850e717358a8b1 (diff)
downloadtdegraphics-546886fdccdc2bc112e6f9eaf99a34aac1d2234e.tar.gz
tdegraphics-546886fdccdc2bc112e6f9eaf99a34aac1d2234e.zip
Move poppler-qt to poppler-tqt and fix build sequence
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegraphics@1237558 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kfile-plugins/dependencies/poppler-tqt/Makefile.am')
-rw-r--r--kfile-plugins/dependencies/poppler-tqt/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/kfile-plugins/dependencies/poppler-tqt/Makefile.am b/kfile-plugins/dependencies/poppler-tqt/Makefile.am
new file mode 100644
index 00000000..435f15e1
--- /dev/null
+++ b/kfile-plugins/dependencies/poppler-tqt/Makefile.am
@@ -0,0 +1,40 @@
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I/usr/include/poppler \
+ $(cairo_includes) \
+ $(QT_INCLUDES) \
+ $(FREETYPE_CFLAGS) \
+ $(FONTCONFIG_CFLAGS)
+
+
+poppler_includedir = $(includedir)/poppler/qt3
+poppler_include_HEADERS = \
+ poppler-qt.h \
+ poppler-page-transition.h \
+ poppler-link-qt3.h
+
+lib_LTLIBRARIES = libpoppler-tqt.la
+libpoppler_tqt_la_SOURCES = \
+ poppler-document.cc \
+ poppler-fontinfo.cc \
+ poppler-link.cc \
+ poppler-page.cc \
+ poppler-page-transition.cc \
+ poppler-page-transition-private.h \
+ poppler-private.cc \
+ poppler-private.h
+
+libpoppler_tqt_la_LIBADD = \
+ -lpoppler \
+ $(QT_LIBS) \
+ $(FREETYPE_LIBS) \
+ $(FONTCONFIG_LIBS)
+
+test_poppler_tqt_SOURCES = \
+ test-poppler-qt.cpp
+
+test_poppler_tqt_LDADD = \
+ $(top_builddir)/poppler/libpoppler.la \
+ libpoppler-tqt.la \
+ $(QT_LIBS) \
+ $(FREETYPE_LIBS)