summaryrefslogtreecommitdiffstats
path: root/kfile-plugins/pdf/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-06-18 21:50:35 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-06-18 21:50:35 +0000
commiteecec9afb81fdebb0f22e9da22635874c403f854 (patch)
tree37ca0e07d569a2d603ef6917b0743995bed1f83b /kfile-plugins/pdf/Makefile.am
parenta6df54bf10ef1af68b5d3104d02bd76296aa785b (diff)
downloadtdegraphics-eecec9afb81fdebb0f22e9da22635874c403f854.tar.gz
tdegraphics-eecec9afb81fdebb0f22e9da22635874c403f854.zip
Merge required poppler-qt into kdegraphics with Autotools
CMake support still needs to be added git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdegraphics@1237420 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kfile-plugins/pdf/Makefile.am')
-rw-r--r--kfile-plugins/pdf/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/kfile-plugins/pdf/Makefile.am b/kfile-plugins/pdf/Makefile.am
index 841d9980..c8af5244 100644
--- a/kfile-plugins/pdf/Makefile.am
+++ b/kfile-plugins/pdf/Makefile.am
@@ -1,7 +1,9 @@
## Makefile.am for the pdf file meta info plugin
+subdirs=poppler-qt
+
# set the include path for X, qt and KDE
-INCLUDES = $(all_includes) $(POPPLER_CFLAGS)
+INCLUDES = $(all_includes) -I$(top_srcdir)/kfile-plugins/pdf/poppler-qt
# these are the headers for your project
noinst_HEADERS = kfile_pdf.h
@@ -10,7 +12,7 @@ kde_module_LTLIBRARIES = kfile_pdf.la
kfile_pdf_la_SOURCES = kfile_pdf.cpp
kfile_pdf_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
-kfile_pdf_la_LIBADD = $(LIB_KIO) $(POPPLER_LIBS)
+kfile_pdf_la_LIBADD = $(LIB_KIO) -L$(top_builddir)/kfile-plugins/pdf/poppler-qt/ -lpoppler-qt
# let automoc handle all of the meta source files (moc)
METASOURCES = AUTO