summaryrefslogtreecommitdiffstats
path: root/kpdf/shell/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
commit837dbafbea0c7f7bc73d27fda684ea2dededd547 (patch)
tree66811931fed182f8fa6f59547c6511a897adb734 /kpdf/shell/CMakeLists.txt
parent00b9084c635fe29e7c5942ff508be2ca65893659 (diff)
downloadtdegraphics-837dbafbea0c7f7bc73d27fda684ea2dededd547.tar.gz
tdegraphics-837dbafbea0c7f7bc73d27fda684ea2dededd547.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kpdf/shell/CMakeLists.txt')
-rw-r--r--kpdf/shell/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/kpdf/shell/CMakeLists.txt b/kpdf/shell/CMakeLists.txt
index 74553840..1794250c 100644
--- a/kpdf/shell/CMakeLists.txt
+++ b/kpdf/shell/CMakeLists.txt
@@ -23,7 +23,11 @@ link_directories(
##### other data ################################
-install( FILES kpdf.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE kpdf.desktop
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kpdf-desktops
+)
+
install( FILES shell.rc DESTINATION ${DATA_INSTALL_DIR}/kpdf )