summaryrefslogtreecommitdiffstats
path: root/kview/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-09 17:49:10 +0200
commit837dbafbea0c7f7bc73d27fda684ea2dededd547 (patch)
tree66811931fed182f8fa6f59547c6511a897adb734 /kview/CMakeLists.txt
parent00b9084c635fe29e7c5942ff508be2ca65893659 (diff)
downloadtdegraphics-837dbafbea0c7f7bc73d27fda684ea2dededd547.tar.gz
tdegraphics-837dbafbea0c7f7bc73d27fda684ea2dededd547.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kview/CMakeLists.txt')
-rw-r--r--kview/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/kview/CMakeLists.txt b/kview/CMakeLists.txt
index c038f009..c75c7c75 100644
--- a/kview/CMakeLists.txt
+++ b/kview/CMakeLists.txt
@@ -31,7 +31,12 @@ link_directories(
##### other data ################################
tde_install_icons( kview )
-install( FILES kview.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+tde_create_translated_desktop(
+ SOURCE kview.desktop
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kview-desktops
+)
+
install( FILES kviewui.rc DESTINATION ${DATA_INSTALL_DIR}/kview )