summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2018-08-26 00:18:56 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2018-08-26 00:18:56 +0900
commita18f9fcc94b6982fecb8b75ccb5c21b213e78706 (patch)
treedb1e3d87eaba2952829717f25a51e9b7a5c18d8c /src/CMakeLists.txt
parent3eaf665507fb178a718ef9f57f2bb9ec908d5ac8 (diff)
downloadtdeio-gopher-a18f9fcc94b6982fecb8b75ccb5c21b213e78706.tar.gz
tdeio-gopher-a18f9fcc94b6982fecb8b75ccb5c21b213e78706.zip
Adapted to TDE and TQt3. Build and work fine. No helpbook or
translation are built yet. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..65045d6
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,40 @@
+
+
+
+#set(tdeio_man_PART_SRCS tdeio_gopher.cpp)
+
+#kde4_add_plugin(tdeio_gopher ${tdeio_man_PART_SRCS})
+
+
+#find_package(Msgfmt REQUIRED)
+#find_package(Gettext REQUIRED)
+#add_subdirectory( po )
+#add_subdirectory( doc-translations )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+#####add_subdirectory(doc)
+
+##### other data ################################
+
+install( FILES gopher.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### tdeio_gopher (module) #######################
+
+set( target tdeio_gopher )
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES tdeio_gopher.cpp
+ LINK tdeio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)