summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..65045d6
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,40 @@
+
+
+
+#set(tdeio_man_PART_SRCS tdeio_gopher.cpp)
+
+#kde4_add_plugin(tdeio_gopher ${tdeio_man_PART_SRCS})
+
+
+#find_package(Msgfmt REQUIRED)
+#find_package(Gettext REQUIRED)
+#add_subdirectory( po )
+#add_subdirectory( doc-translations )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+#####add_subdirectory(doc)
+
+##### other data ################################
+
+install( FILES gopher.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### tdeio_gopher (module) #######################
+
+set( target tdeio_gopher )
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES tdeio_gopher.cpp
+ LINK tdeio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)