summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrançois Andriot <francois.andriot@free.fr>2014-10-05 14:44:34 +0200
committerSlávek Banko <slavek.banko@axis.cz>2015-12-23 02:22:50 +0100
commite4213f01b9eaa5100c31d497f15d87695d18f4cd (patch)
tree5a8790cbe81fa5ae42696b54011e8209449f4222 /CMakeLists.txt
parentf3635faf14a7521e7e9263f197d071a98bdda171 (diff)
downloadtdelibs-e4213f01b9eaa5100c31d497f15d87695d18f4cd.tar.gz
tdelibs-e4213f01b9eaa5100c31d497f15d87695d18f4cd.zip
Fix hardcoded link flag to "dl" library
Fix "dlopen" function detection (cherry picked from commit af2c2afb25ce2b62767cdc639cf6d0c4fb967eaa)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e8b2ff73b..ea892a911 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -463,10 +463,15 @@ set( kde_socklen_t socklen_t )
##### check for libdl ###########################
-find_library( HAVE_LIBDL dl )
-if( NOT HAVE_LIBDL-NOTFOUND )
- set( DL_LIBRARIES dl )
-endif( NOT HAVE_LIBDL-NOTFOUND )
+set( DL_LIBRARIES dl )
+check_library_exists( ${DL_LIBRARIES} dlopen /lib HAVE_LIBDL )
+if( NOT HAVE_LIBDL )
+ unset( DL_LIBRARIES )
+ check_function_exists( dlopen HAVE_DLOPEN )
+ if( HAVE_DLOPEN )
+ set( HAVE_LIBDL 1 )
+ endif( HAVE_DLOPEN )
+endif( NOT HAVE_LIBDL )
##### check for utempter ########################