summaryrefslogtreecommitdiffstats
path: root/dcop/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /dcop/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'dcop/Makefile.am')
-rw-r--r--dcop/Makefile.am69
1 files changed, 69 insertions, 0 deletions
diff --git a/dcop/Makefile.am b/dcop/Makefile.am
new file mode 100644
index 000000000..8dfa033ad
--- /dev/null
+++ b/dcop/Makefile.am
@@ -0,0 +1,69 @@
+# This Makefile.am was taken from the kdelibs distribution and
+# modified for DCOP. Preston Brown (Oct 10, 1999)
+#
+# Copyright (c) 1999 Preston Brown <pbrown@kde.org>
+# Copyright (c) 1999 Matthias Ettrich <ettrich@kde.org>
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# X CONSORTIUM BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
+# AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+SUBDIRS = KDE-ICE . dcopidl dcopidlng dcopidl2cpp client tests
+KDE_OPTIONS = qtonly
+
+INCLUDES = $(all_includes)
+
+bin_PROGRAMS = dcopserver_shutdown
+check_PROGRAMS = testdcop testdcopc dcop_deadlock_test
+
+lib_LTLIBRARIES = libDCOP.la
+libDCOP_la_LIBADD = KDE-ICE/libkICE.la $(LIB_QT)
+libDCOP_la_LDFLAGS = $(KDE_RPATH) -version-info 6:0:2 -no-undefined $(all_libraries)
+libDCOP_la_NMCHECK = $(srcdir)/libDCOP.nmcheck
+libDCOP_la_NMCHECKWEAK = $(srcdir)/libDCOP_weak.nmcheck $(top_srcdir)/kdecore/libqt-mt_weak.nmcheck
+
+include_HEADERS = dcopclient.h dcopobject.h dcopstub.h dcopref.h dcoptypes.h kdatastream.h
+noinst_HEADERS = version.h dcopglobal.h dcopserver.h testdcop.h dcopsignals.h dcop-path.h
+
+METASOURCES = AUTO
+
+# dcopstub needs to go first for --enable-final to work
+libDCOP_la_SOURCES = dcopstub.cpp dcopref.cpp dcopobject.cpp dcopclient.cpp
+
+kdeinit_LTLIBRARIES = dcopserver.la
+dcopserver_la_LDFLAGS = -module -avoid-version $(all_libraries)
+dcopserver_la_SOURCES = dcopserver.cpp dcopsignals.cpp
+dcopserver_la_LIBADD = libDCOP.la
+
+dcopserver_shutdown_SOURCES = dcopserver_shutdown.c
+
+testdcop_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+testdcop_SOURCES = testdcop.cpp
+testdcop_LDADD = libDCOP.la
+
+dcop_deadlock_test_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+dcop_deadlock_test_SOURCES = dcop_deadlock_test.cpp
+dcop_deadlock_test_LDADD = ../kdecore/libkdecore.la
+
+testdcopc_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+testdcopc_SOURCES = testdcopc.c dcopc.c
+testdcopc_LDADD = KDE-ICE/libkICE.la $(LIBSM)
+
+EXTRA_DIST = HOWTO ICE Mainpage.dox
+
+DOXYGEN_REFERENCES = kdecore
+DOXYGEN_EXCLUDE = KDE-ICE
+include ../admin/Doxyfile.am