summaryrefslogtreecommitdiffstats
path: root/kdecore/network/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /kdecore/network/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kdecore/network/Makefile.am')
-rw-r--r--kdecore/network/Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/kdecore/network/Makefile.am b/kdecore/network/Makefile.am
new file mode 100644
index 000000000..71ed013d9
--- /dev/null
+++ b/kdecore/network/Makefile.am
@@ -0,0 +1,59 @@
+## Makefile.am for libqt-addon
+
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+noinst_LTLIBRARIES = libkdecorenetwork.la
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# the library search path.
+# convenience lib - no LDFLAGS or LIBADD !
+# Note:
+# ksocketdevice.cpp must appear before any inclusion of ksocketdevice.h
+libkdecorenetwork_la_SOURCES = kresolver.cpp \
+ kresolvermanager.cpp \
+ kresolverworkerbase.cpp \
+ ksocketaddress.cpp \
+ kresolverstandardworkers.cpp \
+ kreverseresolver.cpp \
+ ksocketdevice.cpp \
+ ksocketbase.cpp \
+ kclientsocketbase.cpp \
+ kstreamsocket.cpp \
+ kserversocket.cpp \
+ kdatagramsocket.cpp \
+ khttpproxysocketdevice.cpp \
+ ksockssocketdevice.cpp \
+ kbufferedsocket.cpp \
+ ksocketbuffer.cpp \
+ ksrvresolverworker.cpp
+
+include_HEADERS = kresolver.h \
+ kreverseresolver.h \
+ ksocketaddress.h \
+ ksocketbase.h \
+ ksocketdevice.h \
+ kclientsocketbase.h \
+ kstreamsocket.h \
+ kserversocket.h \
+ kdatagramsocket.h \
+ kmulticastsocketdevice.h \
+ kmulticastsocket.h \
+ knetworkinterface.h \
+ khttpproxysocketdevice.h \
+ ksockssocketdevice.h \
+ kbufferedsocket.h \
+ kiobuffer.h
+noinst_HEADERS = kresolver_p.h \
+ kresolverworkerbase.h \
+ kresolverstandardworkers_p.h \
+ ksocketbuffer_p.h \
+ ksrvresolverworker_p.h \
+ syssocket.h
+
+configdir = $(kde_confdir)
+config_DATA = ipv6blacklist
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO