summaryrefslogtreecommitdiffstats
path: root/kdoctools/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-16 15:05:00 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-16 15:05:00 +0200
commita94bf7ad14415944b4ed7f6bdded31101c716600 (patch)
tree4bb39c1ca591e49bac11452a6cc6d7eb4337391c /kdoctools/CMakeLists.txt
parent98436f882d2146fe156c26e81bb87d409cfcf819 (diff)
downloadtdelibs-a94bf7ad14415944b4ed7f6bdded31101c716600.tar.gz
tdelibs-a94bf7ad14415944b4ed7f6bdded31101c716600.zip
Prepare the complete ksgmltools2 in the binary directory
instead of updating in the source. The configuration file mechanism is used to update items in general.entities instead of loading the file and replacing it with regular expressions. This relates to bug 3135. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kdoctools/CMakeLists.txt')
-rw-r--r--kdoctools/CMakeLists.txt35
1 files changed, 22 insertions, 13 deletions
diff --git a/kdoctools/CMakeLists.txt b/kdoctools/CMakeLists.txt
index 8657e277e..e12cf7895 100644
--- a/kdoctools/CMakeLists.txt
+++ b/kdoctools/CMakeLists.txt
@@ -37,19 +37,28 @@ install( PROGRAMS move_tdeio_help_cache.sh DESTINATION ${KCONF_UPDATE_INSTALL_DI
install( FILES tdeio_help.upd DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )
install( FILES help.protocol ghelp.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
-# FIXME why automake version is so complicated?
-# install-data-local:
-# @(for subdir in customization docbook; do \
-# for dir in `( cd $(srcdir)/$$subdir && find . -type d ! -name CVS | grep -v '\.svn' )`; do \
-# $(mkinstalldirs) $(DESTDIR)$(kde_datadir)/ksgmltools2/$$subdir/$$dir ;\
-# for file in `(cd $(srcdir)/$$subdir && ls -1 $$dir/*)`; do \
-# if test -f $(srcdir)/$$subdir/$$file; then \
-# $(INSTALL_DATA) $(srcdir)/$$subdir/$$file $(DESTDIR)$(kde_datadir)/ksgmltools2/$$subdir/$$file; fi ;\
-# done ;\
-# done ;\
-# done )
-install( DIRECTORY customization docbook DESTINATION ${DATA_INSTALL_DIR}/ksgmltools2 PATTERN ".svn" EXCLUDE )
-install( FILES man-template.docbook template.docbook DESTINATION ${DATA_INSTALL_DIR}/ksgmltools2 )
+file(
+ COPY
+ customization docbook
+ man-template.docbook template.docbook
+ DESTINATION
+ ${CMAKE_BINARY_DIR}/ksgmltools2
+ PATTERN ".svn" EXCLUDE
+ REGEX "customization/entities/general.entities$" EXCLUDE
+)
+configure_file(
+ customization/entities/general.entities
+ ${CMAKE_BINARY_DIR}/ksgmltools2/customization/entities/general.entities
+ @ONLY
+)
+
+install(
+ DIRECTORY
+ ${CMAKE_BINARY_DIR}/ksgmltools2/
+ DESTINATION
+ ${DATA_INSTALL_DIR}/ksgmltools2
+)
+
##### kbzipfilter_dummy ##############################