summaryrefslogtreecommitdiffstats
path: root/khtml/html/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-10-05 19:41:05 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-10-05 19:41:05 +0000
commit7ffba8afee76edba6433d97864119501731742e8 (patch)
tree38b5eb5bd019b77b33f7ad8d7de7ef7666ebe8b1 /khtml/html/CMakeLists.txt
parent0db4822126702d04068c5761e63ed9684a08981b (diff)
downloadtdelibs-7ffba8afee76edba6433d97864119501731742e8.tar.gz
tdelibs-7ffba8afee76edba6433d97864119501731742e8.zip
[kdelibs] added initial cmake support
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1182854 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'khtml/html/CMakeLists.txt')
-rw-r--r--khtml/html/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/khtml/html/CMakeLists.txt b/khtml/html/CMakeLists.txt
new file mode 100644
index 000000000..4b636dbaa
--- /dev/null
+++ b/khtml/html/CMakeLists.txt
@@ -0,0 +1,48 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_definitions(
+ ${TQT_CFLAGS_OTHER}
+)
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/kdecore
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/khtml
+ ${CMAKE_SOURCE_DIR}/dcop
+ ${CMAKE_SOURCE_DIR}/kdecore
+ ${CMAKE_SOURCE_DIR}/kdeui
+ ${CMAKE_SOURCE_DIR}/kio
+ ${CMAKE_SOURCE_DIR}/kio/kio
+ ${CMAKE_SOURCE_DIR}/kio/kfile
+ ${CMAKE_SOURCE_DIR}/kio/kssl
+ ${CMAKE_SOURCE_DIR}/kutils
+ ${CMAKE_SOURCE_DIR}/kwallet/client
+)
+
+##### khtmlhtml-static ###########################
+
+set( target khtmlhtml )
+
+set( ${target}_SRCS
+ htmlparser.cpp htmltokenizer.cpp dtd.cpp html_headimpl.cpp
+ html_blockimpl.cpp html_elementimpl.cpp html_inlineimpl.cpp
+ html_documentimpl.cpp html_baseimpl.cpp html_imageimpl.cpp
+ html_listimpl.cpp html_miscimpl.cpp html_formimpl.cpp
+ html_objectimpl.cpp html_tableimpl.cpp
+)
+
+tde_add_library( ${target} STATIC_PIC AUTOMOC
+ SOURCES ${${target}_SRCS}
+)