summaryrefslogtreecommitdiffstats
path: root/kio/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-12-31 04:24:59 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-12-31 04:24:59 -0600
commitbe3f8c175f534d88425b983a577e799c76202e38 (patch)
tree1024143f3894e273412ce44bd7530765664a4ea1 /kio/CMakeLists.txt
parent2e95a0338f40a820ea592802357e985cfcbdb388 (diff)
downloadtdelibs-be3f8c175f534d88425b983a577e799c76202e38.tar.gz
tdelibs-be3f8c175f534d88425b983a577e799c76202e38.zip
Fix up elficon support
Diffstat (limited to 'kio/CMakeLists.txt')
-rw-r--r--kio/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/kio/CMakeLists.txt b/kio/CMakeLists.txt
index 73c2c9dba..2c1d8ff0d 100644
--- a/kio/CMakeLists.txt
+++ b/kio/CMakeLists.txt
@@ -51,6 +51,11 @@ install( FILES kpasswdserver.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kded )
install( FILES data.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+if( HAVE_ELFICON )
+ set( ELFICON_STATIC_LIB tdelficon-static )
+endif( HAVE_ELFICON )
+
+
##### libkio ####################################
set( target kio )
@@ -60,7 +65,7 @@ configure_file( ${CMAKE_SOURCE_DIR}/cmake/modules/template_dummy_cpp.cmake dummy
tde_add_library( ${target} SHARED
SOURCES ${CMAKE_CURRENT_BINARY_DIR}/dummy.cpp
VERSION 4.2.0
- EMBED kssl-static kiocore-static ksycoca-static kbookmarks-static kfile-static
+ EMBED kssl-static kiocore-static ksycoca-static kbookmarks-static kfile-static ${ELFICON_STATIC_LIB}
LINK tdeui-shared tdesu-shared kwalletclient-shared ${LIBR_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}
)