summaryrefslogtreecommitdiffstats
path: root/kio/kioexec/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-10-24 21:53:26 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-10-24 21:53:26 +0000
commit40fe6a00b6dde631a68e40731fabb71680a5454c (patch)
tree8e06828694f6a83f427c022e6b44e911eb7e9ed9 /kio/kioexec/CMakeLists.txt
parent6e5ec36b7925e29501aaf12fe5ae5e58d590f63f (diff)
downloadtdelibs-40fe6a00b6dde631a68e40731fabb71680a5454c.tar.gz
tdelibs-40fe6a00b6dde631a68e40731fabb71680a5454c.zip
[kdelibs] follow KDE4 rules for install path names and some other small changes
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1189382 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kio/kioexec/CMakeLists.txt')
-rw-r--r--kio/kioexec/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/kio/kioexec/CMakeLists.txt b/kio/kioexec/CMakeLists.txt
index 995141c0d..043f017c6 100644
--- a/kio/kioexec/CMakeLists.txt
+++ b/kio/kioexec/CMakeLists.txt
@@ -43,7 +43,4 @@ tde_add_executable( ${target} AUTOMOC
DESTINATION ${BIN_INSTALL_DIR}
)
-# FIXME need a review
-# create symlink to kfmexec
-file( WRITE ${CMAKE_CURRENT_BINARY_DIR}/make_kfmexec_symlink.cmake "exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${target} \"\$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${BIN_INSTALL_DIR}/kfmexec\")\n")
-set_target_properties( ${target} PROPERTIES POST_INSTALL_SCRIPT ${CMAKE_CURRENT_BINARY_DIR}/make_kfmexec_symlink.cmake)
+tde_install_symlink( ${target} ${BIN_INSTALL_DIR}/kfmexec )