summaryrefslogtreecommitdiffstats
path: root/kio/misc/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitce4a32fe52ef09d8f5ff1dd22c001110902b60a2 (patch)
tree5ac38a06f3dde268dc7927dc155896926aaf7012 /kio/misc/Makefile.am
downloadtdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.tar.gz
tdelibs-ce4a32fe52ef09d8f5ff1dd22c001110902b60a2.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdelibs@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kio/misc/Makefile.am')
-rw-r--r--kio/misc/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/kio/misc/Makefile.am b/kio/misc/Makefile.am
new file mode 100644
index 000000000..5dab3a23e
--- /dev/null
+++ b/kio/misc/Makefile.am
@@ -0,0 +1,60 @@
+# This file is part of the KDE libraries
+# Copyright (C) 1997 Torben Weis (weis@kde.org)
+
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+
+# You should have received a copy of the GNU Library General Public License
+# along with this library; see the file COPYING.LIB. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+
+AM_CPPFLAGS = -D_LARGEFILE64_SOURCE
+
+INCLUDES= -I$(srcdir)/.. -I$(top_srcdir) -I$(srcdir)/../kssl -I../kssl $(all_includes) $(SSL_INCLUDES)
+
+SUBDIRS = . ksendbugmail kpac kdesasl kssld kfile kwalletd kntlm
+
+lib_LTLIBRARIES =
+kdeinit_LTLIBRARIES = kio_uiserver.la
+bin_PROGRAMS = kmailservice ktelnetservice
+
+observer_DIR = $(top_srcdir)/kio/kio
+
+kio_uiserver_la_SOURCES = uiserver.cpp uiserver.skel observer.stub
+kio_uiserver_la_LIBADD = $(LIB_KIO)
+kio_uiserver_la_LDFLAGS = $(all_libraries) -module -avoid-version
+
+METASOURCES = AUTO
+
+kde_services_DATA = kio_uiserver.desktop
+
+kmailservice_SOURCES = kmailservice.cpp
+kmailservice_LDADD = $(LIB_KDECORE)
+kmailservice_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+
+ktelnetservice_SOURCES = ktelnetservice.cpp
+ktelnetservice_LDADD = $(LIB_KDEUI)
+ktelnetservice_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+
+protocol_DATA = kmailservice.protocol telnet.protocol rlogin.protocol rtsp.protocol ssh.protocol \
+ mms.protocol mmst.protocol mmsu.protocol pnm.protocol rtspt.protocol rtspu.protocol
+protocoldir = $(kde_servicesdir)
+
+kiomiscdir = $(includedir)/kio
+kiomisc_HEADERS = uiserver.h
+
+
+bin_SCRIPTS = fileshareset
+install-exec-local:
+ @-rm -f $(DESTDIR)$(bindir)/filesharelist
+ @$(LN_S) fileshareset $(DESTDIR)$(bindir)/filesharelist
+ @(chown root $(DESTDIR)$(bindir)/fileshareset && chmod 4755 $(DESTDIR)$(bindir)/fileshareset) || echo "Was not able to make fileshareset setuid root"
+