summaryrefslogtreecommitdiffstats
path: root/tdecore/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-08-23 18:19:49 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-08-23 18:19:49 -0500
commit32e6eba8731f7f3328ae287d0493d941dadec06f (patch)
treeac81ffbe137bb27cbd5681f25324f2ae340cd294 /tdecore/CMakeLists.txt
parent38f05d1e1d61ac758d820a3923e2922337d9908e (diff)
downloadtdelibs-32e6eba8731f7f3328ae287d0493d941dadec06f.tar.gz
tdelibs-32e6eba8731f7f3328ae287d0493d941dadec06f.zip
Initial skeleton for network manager support
Diffstat (limited to 'tdecore/CMakeLists.txt')
-rw-r--r--tdecore/CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/tdecore/CMakeLists.txt b/tdecore/CMakeLists.txt
index 4fa1e4cca..a684dc59c 100644
--- a/tdecore/CMakeLists.txt
+++ b/tdecore/CMakeLists.txt
@@ -14,11 +14,18 @@ add_subdirectory( network )
add_subdirectory( kconfig_compiler )
add_subdirectory( hwlibdata )
+
if( WITH_LIBART )
add_subdirectory( svgicons )
set( KDESVGICONS kdesvgicons-static )
endif( WITH_LIBART )
+if( WITH_NETWORK_MANAGER_BACKEND )
+ add_subdirectory( networkbackends/network-manager/dbus )
+ set ( TDENM_LIBRARIES tdenm_dbus-static )
+ set ( TDENM_BACKEND_SOURCES networkbackends/network-manager/network-manager.cpp )
+endif( WITH_NETWORK_MANAGER_BACKEND )
+
include_directories(
${TQT_INCLUDE_DIRS}
@@ -42,7 +49,6 @@ link_directories(
${GAMIN_LIBDIR}
)
-
##### headers ###################################
install( FILES
@@ -70,6 +76,7 @@ install( FILES
kmanagerselection.h kmountpoint.h kuser.h klockfile.h
kidna.h ktempdir.h kshell.h fixx11h.h kxerrorhandler.h
tdelibs_export.h kde_file.h ktimezones.h tdehardwaredevices.h
+ tdenetworkconnections.h
${CMAKE_CURRENT_BINARY_DIR}/kdemacros.h
DESTINATION ${INCLUDE_INSTALL_DIR} )
@@ -125,14 +132,16 @@ set( ${target}_SRCS
ktempdir.cpp kshell.cpp kmountpoint.cpp kcalendarsystemjalali.cpp
kprotocolinfo_tdecore.cpp kprotocolinfofactory.cpp kxerrorhandler.cpp
kuser.cpp kconfigskeleton.cpp kconfigdialogmanager.cpp klockfile.cpp
- kqiodevicegzip_p.cpp ktimezones.cpp tdehardwaredevices.cpp ksimpledirwatch.cpp
+ kqiodevicegzip_p.cpp ktimezones.cpp tdehardwaredevices.cpp tdenetworkconnections.cpp
+ ksimpledirwatch.cpp
+ ${TDENM_BACKEND_SOURCES}
)
tde_add_library( ${target} SHARED AUTOMOC
SOURCES ${${target}_SRCS}
VERSION 4.2.0
EMBED tdecorenetwork-static
- LINK ltdlc-static ${KDESVGICONS} DCOP-shared tdefx-shared ${ZLIB_LIBRARIES} ${LIBIDN_LIBRARIES} ${XCOMPOSITE_LIBRARIES} ICE SM udev ${GAMIN_LIBRARIES}
+ LINK ltdlc-static ${KDESVGICONS} DCOP-shared tdefx-shared ${ZLIB_LIBRARIES} ${LIBIDN_LIBRARIES} ${XCOMPOSITE_LIBRARIES} ICE SM udev ${GAMIN_LIBRARIES} ${TDENM_LIBRARIES}
DEPENDENCIES dcopidl dcopidl2cpp
DESTINATION ${LIB_INSTALL_DIR}
)