summaryrefslogtreecommitdiffstats
path: root/tdecore/tdehw/CMakeLists.txt
diff options
context:
space:
mode:
authorGolubev Alexander <fatzer2@gmail.com>2013-07-27 02:35:30 +0400
committerGolubev Alexander <fatzer2@gmail.com>2013-07-27 11:20:30 +0400
commit8bc5f3a2940f27486ae31b83a9b7cd74076b4885 (patch)
tree71b3776519152a27fa1ee12ef76507afb6520122 /tdecore/tdehw/CMakeLists.txt
parent0984f0194709db2d85651615b0551054876dbcc5 (diff)
downloadtdelibs-8bc5f3a2940f27486ae31b83a9b7cd74076b4885.tar.gz
tdelibs-8bc5f3a2940f27486ae31b83a9b7cd74076b4885.zip
moved first two classes of tdehw to their own files
Diffstat (limited to 'tdecore/tdehw/CMakeLists.txt')
-rw-r--r--tdecore/tdehw/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/tdecore/tdehw/CMakeLists.txt b/tdecore/tdehw/CMakeLists.txt
index 960158cea..af050ed0e 100644
--- a/tdecore/tdehw/CMakeLists.txt
+++ b/tdecore/tdehw/CMakeLists.txt
@@ -63,7 +63,8 @@ link_directories(
##### headers ###################################
-install( FILES tdehardwaredevices.h tdenetworkconnections.h
+install( FILES tdehardwaredevices.h tdenetworkconnections.h tdegenericdevice.h
+ tdestoragedevice.h
DESTINATION ${INCLUDE_INSTALL_DIR} )
@@ -72,7 +73,8 @@ install( FILES tdehardwaredevices.h tdenetworkconnections.h
set( target tdehw )
set( ${target}_SRCS
- tdehardwaredevices.cpp tdenetworkconnections.cpp
+ tdehardwaredevices.cpp tdenetworkconnections.cpp tdegenericdevice.cpp
+ tdestoragedevice.cpp
)
tde_add_library( ${target} STATIC_PIC AUTOMOC