summaryrefslogtreecommitdiffstats
path: root/tdeioslave/gzip/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
commit5159cd2beb2e87806a5b54e9991b7895285c9d3e (patch)
tree9b70e8be47a390f8f4d56ead812ab0c9dad88709 /tdeioslave/gzip/Makefile.am
parentc17cb900dcf52b8bd6dc300d4f103392900ec2b4 (diff)
downloadtdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.tar.gz
tdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/gzip/Makefile.am')
-rw-r--r--tdeioslave/gzip/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/tdeioslave/gzip/Makefile.am b/tdeioslave/gzip/Makefile.am
new file mode 100644
index 000000000..22918aef2
--- /dev/null
+++ b/tdeioslave/gzip/Makefile.am
@@ -0,0 +1,12 @@
+INCLUDES = -I$(top_srcdir)/tdeio $(all_includes)
+AM_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kgzipfilter.la
+
+kgzipfilter_la_SOURCES = kgzipfilter.cpp
+kgzipfilter_la_LIBADD = $(LIB_KIO) $(LIBZ) $(LIB_QT) $(LIB_TDECORE)
+kgzipfilter_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+kde_services_DATA = kgzipfilter.desktop
+