summaryrefslogtreecommitdiffstats
path: root/tdeprint/lpdunix/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:40 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:40 -0600
commite16866e072f94410321d70daedbcb855ea878cac (patch)
treeee3f52eabde7da1a0e6ca845fb9c2813cf1558cf /tdeprint/lpdunix/CMakeLists.txt
parenta58c20c1a7593631a1b50213c805507ebc16adaf (diff)
downloadtdelibs-e16866e072f94410321d70daedbcb855ea878cac.tar.gz
tdelibs-e16866e072f94410321d70daedbcb855ea878cac.zip
Actually move the kde files that were renamed in the last commit
Diffstat (limited to 'tdeprint/lpdunix/CMakeLists.txt')
-rw-r--r--tdeprint/lpdunix/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/tdeprint/lpdunix/CMakeLists.txt b/tdeprint/lpdunix/CMakeLists.txt
new file mode 100644
index 000000000..5b30cf46c
--- /dev/null
+++ b/tdeprint/lpdunix/CMakeLists.txt
@@ -0,0 +1,52 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_definitions(
+ -D_KDEPRINT_COMPILE
+)
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/dcop
+ ${CMAKE_SOURCE_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdeui
+ ${CMAKE_SOURCE_DIR}/tdeprint
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES lpdunix.print DESTINATION ${DATA_INSTALL_DIR}/tdeprint/plugins )
+
+
+#### tdeprint_lpdunix ###########################
+
+set( target tdeprint_lpdunix )
+
+set( ${target}_SRCS
+ kmlpdunixfactory.cpp kmlpdunixmanager.cpp
+ klpdunixprinterimpl.cpp kmlpdunixuimanager.cpp
+)
+
+tde_add_kpart( ${target}
+ SOURCES ${${target}_SRCS}
+ LINK tdeprint-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)