summaryrefslogtreecommitdiffstats
path: root/tdeprint/lpdunix/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:40 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:40 -0600
commite16866e072f94410321d70daedbcb855ea878cac (patch)
treeee3f52eabde7da1a0e6ca845fb9c2813cf1558cf /tdeprint/lpdunix/Makefile.am
parenta58c20c1a7593631a1b50213c805507ebc16adaf (diff)
downloadtdelibs-e16866e072f94410321d70daedbcb855ea878cac.tar.gz
tdelibs-e16866e072f94410321d70daedbcb855ea878cac.zip
Actually move the kde files that were renamed in the last commit
Diffstat (limited to 'tdeprint/lpdunix/Makefile.am')
-rw-r--r--tdeprint/lpdunix/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tdeprint/lpdunix/Makefile.am b/tdeprint/lpdunix/Makefile.am
new file mode 100644
index 000000000..019ead755
--- /dev/null
+++ b/tdeprint/lpdunix/Makefile.am
@@ -0,0 +1,15 @@
+AM_CPPFLAGS = -D_KDEPRINT_COMPILE
+
+INCLUDES= -I$(top_srcdir) -I$(top_srcdir)/tdeprint $(all_includes)
+
+kde_module_LTLIBRARIES = tdeprint_lpdunix.la
+
+tdeprint_lpdunix_la_SOURCES = kmlpdunixfactory.cpp kmlpdunixmanager.cpp klpdunixprinterimpl.cpp kmlpdunixuimanager.cpp
+tdeprint_lpdunix_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+tdeprint_lpdunix_la_LIBADD = $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEPRINT)
+tdeprint_lpdunix_la_METASOURCES = AUTO
+
+noinst_HEADERS = kmlpdunixmanager.h klpdunixprinterimpl.h kmlpdunixuimanager.h
+
+entry_DATA = lpdunix.print
+entrydir = $(kde_datadir)/tdeprint/plugins