summaryrefslogtreecommitdiffstats
path: root/kinit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kinit/CMakeLists.txt')
-rw-r--r--kinit/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/kinit/CMakeLists.txt b/kinit/CMakeLists.txt
index 73dbfb15e..db4da097a 100644
--- a/kinit/CMakeLists.txt
+++ b/kinit/CMakeLists.txt
@@ -140,7 +140,11 @@ tde_add_executable( ${target} ${_setuid}
DESTINATION ${BIN_INSTALL_DIR}
)
-set_target_properties( ${target} PROPERTIES COMPILE_FLAGS -DEXECUTE=\\"${BIN_INSTALL_DIR}/kdeinit\\" )
+set_property(
+ TARGET ${target}
+ APPEND PROPERTY COMPILE_DEFINITIONS
+ EXECUTE="${BIN_INSTALL_DIR}/kdeinit"
+)
#### start_kdeinit_wrapper ######################