summaryrefslogtreecommitdiffstats
path: root/kspell2/plugins/hspell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kspell2/plugins/hspell/Makefile.am')
-rw-r--r--kspell2/plugins/hspell/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kspell2/plugins/hspell/Makefile.am b/kspell2/plugins/hspell/Makefile.am
new file mode 100644
index 000000000..8f9b4e982
--- /dev/null
+++ b/kspell2/plugins/hspell/Makefile.am
@@ -0,0 +1,17 @@
+METASOURCES = AUTO
+
+AM_CPPFLAGS = -I$(top_srcdir)/kspell2 -I$(top_srcdir) $(all_includes)
+
+# For the future: examine if condensing the tons of *_LDFLAGS variables
+# into $(all_libraries) isn't better
+AM_LDFLAGS = $(LDFLAGS_AS_NEEDED) $(LDFLAGS_NEW_DTAGS)
+
+kde_module_LTLIBRARIES = kspell_hspell.la
+
+kspell_hspell_la_SOURCES = kspell_hspellclient.cpp kspell_hspelldict.cpp
+
+kspell_hspell_la_LDFLAGS = -module -no-undefined $(KDE_PLUGIN)
+kspell_hspell_la_LIBADD = ../../ui/libkspell2.la -lhspell -lz
+
+service_DATA = kspell_hspell.desktop
+servicedir = $(kde_servicesdir)