summaryrefslogtreecommitdiffstats
path: root/kmix/pics/CMakeLists.txt
diff options
context:
space:
mode:
authorMavridis Philippe <mavridisf@gmail.com>2021-12-12 16:24:28 +0200
committerMavridis Philippe <mavridisf@gmail.com>2024-03-28 18:47:19 +0200
commitd1b9bae155425c2d500b136111cc4f2f28fc0c16 (patch)
tree5e0309e574fd8762cbd0b5dfdcbad176d18b459c /kmix/pics/CMakeLists.txt
parentd2ab59b4284b371fb9e7cb143c3632e379d339b7 (diff)
downloadtdemultimedia-d1b9bae155425c2d500b136111cc4f2f28fc0c16.tar.gz
tdemultimedia-d1b9bae155425c2d500b136111cc4f2f28fc0c16.zip
KMix: system tray icon enhancements
* XDG-compliant icon names with volume level specification (low, medium, high) Low-Medium threshold: 33% Medium-High threshold: 67% * Improved built-in icon theme with distinct volume levels (according to above) * Choice between classic KMix icon theme, imrpoved KMix icon theme and system theme. * New KMixDockWidget::getAvgVolume() method Gets average volume in %. Code actually comes from KMixDockWidget::setVolumeTip(), but was put into a separate method to be reused for determination of icon according to the volume level (cherry picked from commit 3168c39ef1e445db1a6e22a7ba63e8cb4714e6e8)
Diffstat (limited to 'kmix/pics/CMakeLists.txt')
-rw-r--r--kmix/pics/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/kmix/pics/CMakeLists.txt b/kmix/pics/CMakeLists.txt
index 35ea82c5..92af67f8 100644
--- a/kmix/pics/CMakeLists.txt
+++ b/kmix/pics/CMakeLists.txt
@@ -16,8 +16,10 @@ install( FILES
mix_microphone.png mix_midi.png mix_recmon.png
mix_treble.png mix_unknown.png mix_volume.png
mix_surround.png mix_video.png mix_headphone.png
- mix_digital.png mix_ac97.png kmixdocked.png
- kmixdocked_mute.png kmixdocked_error.png mix_record.png
+ mix_digital.png mix_ac97.png mix_record.png
SpeakerFrontLeft.png SpeakerRearLeft.png SpeakerFrontRight.png
SpeakerRearRight.png Listener.png
DESTINATION ${DATA_INSTALL_DIR}/kmix/pics )
+
+add_subdirectory(oldcrystal)
+add_subdirectory(crystal) \ No newline at end of file