summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/wav/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-30 00:57:03 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-30 00:57:05 +0200
commitff3f2006ce72b2edabc534188a4ad006e89b4f84 (patch)
treec81f41ffa6e329ddadd048e07b553af2154f5e16 /tdefile-plugins/wav/CMakeLists.txt
parent9817ad52c6376ae54f5e4e4d11a31d958cc85faa (diff)
downloadtdemultimedia-ff3f2006ce72b2edabc534188a4ad006e89b4f84.tar.gz
tdemultimedia-ff3f2006ce72b2edabc534188a4ad006e89b4f84.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tdefile-plugins/wav/CMakeLists.txt')
-rw-r--r--tdefile-plugins/wav/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tdefile-plugins/wav/CMakeLists.txt b/tdefile-plugins/wav/CMakeLists.txt
index 30a95083..c0d39017 100644
--- a/tdefile-plugins/wav/CMakeLists.txt
+++ b/tdefile-plugins/wav/CMakeLists.txt
@@ -36,4 +36,8 @@ tde_add_kpart( tdefile_wav AUTOMOC
##### other data ################################
-install( FILES tdefile_wav.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE tdefile_wav.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdefile-desktops
+)