summaryrefslogtreecommitdiffstats
path: root/tdeioslave/audiocd/kcmaudiocd/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:32 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:32 -0600
commit793cf2dff35dffe3ec4c7b24252947dde758a1b2 (patch)
tree7d9972d99ed281a36418ae9f5fc128e3c951532c /tdeioslave/audiocd/kcmaudiocd/Makefile.am
parent04f764aaf273340e1d5811d4216dd8127cacc5db (diff)
downloadtdemultimedia-793cf2dff35dffe3ec4c7b24252947dde758a1b2.tar.gz
tdemultimedia-793cf2dff35dffe3ec4c7b24252947dde758a1b2.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/audiocd/kcmaudiocd/Makefile.am')
-rw-r--r--tdeioslave/audiocd/kcmaudiocd/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/tdeioslave/audiocd/kcmaudiocd/Makefile.am b/tdeioslave/audiocd/kcmaudiocd/Makefile.am
new file mode 100644
index 00000000..73d6be2d
--- /dev/null
+++ b/tdeioslave/audiocd/kcmaudiocd/Makefile.am
@@ -0,0 +1,17 @@
+kde_module_LTLIBRARIES = kcm_audiocd.la
+
+kcm_audiocd_la_SOURCES = audiocdconfig.ui kcmaudiocd.cpp
+
+kcm_audiocd_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+kcm_audiocd_la_LIBADD = ../plugins/libaudiocdplugins.la $(LIB_TDEUI)
+
+INCLUDES = -I$(srcdir)/../plugins -I$(top_srcdir)/libkcddb $(all_includes)
+
+kcm_audiocd_la_METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmaudiocd.pot
+
+xdg_apps_DATA = audiocd.desktop
+
+audiocdconfig.cpp: audiocdconfig.h