summaryrefslogtreecommitdiffstats
path: root/tdeioslave/audiocd/plugins/flac/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:32 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:32 -0600
commit793cf2dff35dffe3ec4c7b24252947dde758a1b2 (patch)
tree7d9972d99ed281a36418ae9f5fc128e3c951532c /tdeioslave/audiocd/plugins/flac/Makefile.am
parent04f764aaf273340e1d5811d4216dd8127cacc5db (diff)
downloadtdemultimedia-793cf2dff35dffe3ec4c7b24252947dde758a1b2.tar.gz
tdemultimedia-793cf2dff35dffe3ec4c7b24252947dde758a1b2.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/audiocd/plugins/flac/Makefile.am')
-rw-r--r--tdeioslave/audiocd/plugins/flac/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/tdeioslave/audiocd/plugins/flac/Makefile.am b/tdeioslave/audiocd/plugins/flac/Makefile.am
new file mode 100644
index 00000000..4e693c53
--- /dev/null
+++ b/tdeioslave/audiocd/plugins/flac/Makefile.am
@@ -0,0 +1,13 @@
+INCLUDES = -I$(top_srcdir)/libkcddb -I$(srcdir)/.. $(all_includes)
+
+kde_module_LTLIBRARIES = libaudiocd_encoder_flac.la
+
+libaudiocd_encoder_flac_la_SOURCES = encoderflac.cpp
+
+libaudiocd_encoder_flac_la_LIBADD = $(LIBFLAC) $(LIB_KIO) ../libaudiocdplugins.la
+
+libaudiocd_encoder_flac_la_LDFLAGS = -avoid-version -module -no-undefined $(all_libraries)
+
+pluginsdir = $(kde_datadir)/audiocd/plugins
+
+METASOURCES = AUTO