summaryrefslogtreecommitdiffstats
path: root/noatun/app/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'noatun/app/CMakeLists.txt')
-rw-r--r--noatun/app/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/noatun/app/CMakeLists.txt b/noatun/app/CMakeLists.txt
new file mode 100644
index 00000000..ccdf0687
--- /dev/null
+++ b/noatun/app/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}/../library
+ ${CMAKE_BINARY_DIR}
+ ${ARTS_INCLUDE_DIRS}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ARTS_LIBRARY_DIRS}
+)
+
+
+##### noatun (tdeinit) ##########################
+
+tde_add_tdeinit_executable( noatun AUTOMOC
+ SOURCES
+ main.cpp
+ LINK
+ noatun-shared
+ mcop qtmcop kmedia2_idl soundserver_idl artsflow_idl
+)