summaryrefslogtreecommitdiffstats
path: root/noatun/library/noatuntags/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'noatun/library/noatuntags/CMakeLists.txt')
-rw-r--r--noatun/library/noatuntags/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/noatun/library/noatuntags/CMakeLists.txt b/noatun/library/noatuntags/CMakeLists.txt
new file mode 100644
index 00000000..e880ea02
--- /dev/null
+++ b/noatun/library/noatuntags/CMakeLists.txt
@@ -0,0 +1,40 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}/../
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${ARTS_LIBRARY_DIRS}
+)
+
+
+##### noatuntags (library) ######################
+
+tde_add_library( noatuntags SHARED AUTOMOC
+ SOURCES
+ tags.cpp
+ VERSION 1.2.0
+ LINK
+ noatun-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES tags.h DESTINATION ${INCLUDE_INSTALL_DIR}/noatun )