summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-06-09 21:37:18 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-06-09 21:37:18 +0000
commit92489fb3e0c75b300639fd4e961ee131a3e1d521 (patch)
tree18ab3e036e49cf68423b61cb7b12d1b4622a6369 /CMakeLists.txt
parentac87680632b4fb6582d1391b042eff7f0305c0a2 (diff)
downloadtdenetwork-92489fb3e0c75b300639fd4e961ee131a3e1d521.tar.gz
tdenetwork-92489fb3e0c75b300639fd4e961ee131a3e1d521.zip
[kdenetwork] added cmake support for librss and dcoprss
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1235856 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e2fc1fd4..bf072bed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -90,7 +90,9 @@ option( BUILD_KOPETE_PLUGIN_SMPPPDCS "Build smpppdcs kopete plugin" ${BUILD_KOPE
##### user requested modules ####################
option( BUILD_ALL "Build all" OFF )
+option( BUILD_DCOPRSS "Build dcoprss" ${BUILD_ALL} )
option( BUILD_KOPETE "Build kopete" ${BUILD_ALL} )
+option( BUILD_LIBRSS "Build librss" ${BUILD_ALL} )
##### configure checks ##########################
@@ -111,7 +113,9 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### kdenetwork directories ####################
+tde_conditional_add_subdirectory( BUILD_DCOPRSS dcoprss )
tde_conditional_add_subdirectory( BUILD_KOPETE kopete )
+tde_conditional_add_subdirectory( BUILD_LIBRSS librss )
##### write configure files #####################