summaryrefslogtreecommitdiffstats
path: root/filesharing/advanced/kcm_sambaconf/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commitbcb704366cb5e333a626c18c308c7e0448a8e69f (patch)
treef0d6ab7d78ecdd9207cf46536376b44b91a1ca71 /filesharing/advanced/kcm_sambaconf/Makefile.am
downloadtdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.tar.gz
tdenetwork-bcb704366cb5e333a626c18c308c7e0448a8e69f.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'filesharing/advanced/kcm_sambaconf/Makefile.am')
-rw-r--r--filesharing/advanced/kcm_sambaconf/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/filesharing/advanced/kcm_sambaconf/Makefile.am b/filesharing/advanced/kcm_sambaconf/Makefile.am
new file mode 100644
index 00000000..55cd699d
--- /dev/null
+++ b/filesharing/advanced/kcm_sambaconf/Makefile.am
@@ -0,0 +1,46 @@
+KDE_ICON = AUTO
+noinst_LTLIBRARIES = libfilesharesamba.la
+kde_module_LTLIBRARIES = kcm_kcmsambaconf.la
+
+AM_CPPFLAGS = $(all_includes)
+METASOURCES=AUTO
+
+kcm_kcmsambaconf_la_SOURCES = \
+ kcminterface.ui \
+ kcmprinterdlg.ui \
+ printerdlgimpl.cpp \
+ kcmsambaconf.cpp \
+ joindomaindlg.ui
+kcm_kcmsambaconf_la_COMPILE_FIRST = usertab.h share.h
+
+
+kcm_kcmsambaconf_la_LIBADD = \
+ -lkdeprint \
+ libfilesharesamba.la
+
+kcm_kcmsambaconf_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+libfilesharesamba_la_SOURCES = \
+ sambafile.cpp \
+ share.ui \
+ sharedlgimpl.cpp \
+ sambashare.cpp \
+ socketoptionsdlg.ui \
+ common.cpp \
+ userselectdlg.ui \
+ groupselectdlg.ui \
+ usertab.ui \
+ usertabimpl.cpp \
+ filemodedlg.ui \
+ filemodedlgimpl.cpp \
+ smbpasswdfile.cpp \
+ passwd.cpp \
+ hiddenfileview.cpp \
+ dictmanager.cpp \
+ qmultichecklistitem.cpp \
+ smbconfconfigwidget.cpp \
+ linuxpermissionchecker.cpp \
+ expertuserdlg.ui
+
+
+xdg_apps_DATA = kcmsambaconf.desktop