summaryrefslogtreecommitdiffstats
path: root/kopete/libkopete/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-05-22 20:12:04 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-05-22 20:12:04 +0000
commitac87680632b4fb6582d1391b042eff7f0305c0a2 (patch)
treebfeee57d104a1bbc7c387d35190fa55d692115b7 /kopete/libkopete/CMakeLists.txt
parentaca844682f86c04f6b67b23de2a820fb0c63a32e (diff)
downloadtdenetwork-ac87680632b4fb6582d1391b042eff7f0305c0a2.tar.gz
tdenetwork-ac87680632b4fb6582d1391b042eff7f0305c0a2.zip
[kdenetwork/kopete] added cmake support
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdenetwork@1233119 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kopete/libkopete/CMakeLists.txt')
-rw-r--r--kopete/libkopete/CMakeLists.txt91
1 files changed, 91 insertions, 0 deletions
diff --git a/kopete/libkopete/CMakeLists.txt b/kopete/libkopete/CMakeLists.txt
new file mode 100644
index 00000000..bbed2548
--- /dev/null
+++ b/kopete/libkopete/CMakeLists.txt
@@ -0,0 +1,91 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+# FIXME no support for XSS and XRENDER yet
+
+add_subdirectory( private )
+add_subdirectory( ui )
+add_subdirectory( avdevice )
+
+add_definitions( -DKDE_NO_COMPAT )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}/ui
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/private
+ ${CMAKE_CURRENT_SOURCE_DIR}/ui
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ kopeteaccount.h kopeteaccountmanager.h kopeteawayaction.h
+ kopeteawaydialog.h kopeteaway.h kopetecommandhandler.h
+ kopetecontact.h kopetecontactlistelement.h kopetecontactlist.h
+ kopetecontactproperty.h kopeteeventpresentation.h
+ kopete_export.h kopeteglobal.h kopetegroup.h kopetemessageevent.h
+ kopetemessage.h kopetemessagehandlerchain.h kopetemessagehandler.h
+ kopetechatsession.h kopetechatsessionmanager.h kopetemetacontact.h
+ kopetemimetypehandler.h kopeteonlinestatus.h kopeteonlinestatusmanager.h
+ kopetepasswordedaccount.h kopetepassword.h kopeteplugin.h
+ kopeteprotocol.h kopetesimplemessagehandler.h kopetetask.h
+ kopetetransfermanager.h kopeteuiglobal.h kabcpersistence.h
+ managedconnectionaccount.h kopetenotifydataobject.h
+ kopeteversion.h kopeteprefs.h kopetepicture.h webcamwidget.h
+ kopetepluginmanager.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/kopete )
+
+
+##### other data ################################
+
+install( FILES kopete.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
+install( FILES kopetecommandui.rc DESTINATION ${DATA_INSTALL_DIR}/kopete )
+install( FILES kopeteplugin.desktop kopeteprotocol.desktop kopeteui.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+
+
+##### kopete (shared) ###########################
+
+tde_include_tqt( kopetemimetypehandler.cpp )
+
+tde_add_library( kopete SHARED AUTOMOC
+ SOURCES
+ knotification.cpp connectionmanager.cpp kopeteonlinestatus.cpp
+ kopeteonlinestatusmanager.cpp kopeteprotocol.cpp
+ kopetecontact.cpp kopetepluginmanager.cpp kopeteplugin.cpp
+ kopetemessage.cpp kopetechatsession.cpp kopetechatsessionmanager.cpp
+ kopetecontactlist.cpp kopetemetacontact.cpp kopeteawaydialog.cpp
+ kopetetransfermanager.cpp kopetegroup.cpp kcautoconfigmodule.cpp
+ kopeteaccountmanager.cpp kopeteaccount.cpp kopetecontactlistelement.cpp
+ kopetecommandhandler.cpp kopeteaway.cpp kopeteawayaction.cpp
+ kautoconfig.cpp kopetewalletmanager.cpp kopetecontactproperty.cpp
+ kopetepassword.cpp kopeteglobal.cpp kopeteuiglobal.cpp
+ kopetepasswordedaccount.cpp kopetemimetypehandler.cpp
+ kopetetask.cpp kopetemimesourcefactory.cpp kopeteeventpresentation.cpp
+ kopetenotifyevent.cpp kopetenotifydataobject.cpp kopeteblacklister.cpp
+ kopetemessageevent.cpp kopetemessagehandler.cpp kopetemessagehandlerchain.cpp
+ kopetesimplemessagehandler.cpp kopeteproperties.cpp kabcpersistence.cpp
+ connectionmanager.skel clientiface.stub managedconnectionaccount.cpp
+ networkstatuscommon.h kopeteconfig.kcfgc kopeteutils.cpp
+ kopeteprefs.cpp kopetepicture.cpp webcamwidget.cpp
+ VERSION 1.0.0
+ EMBED kopeteui-static
+ LINK kopeteprivate-static kabc-shared kutils-shared khtml-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)