summaryrefslogtreecommitdiffstats
path: root/kopete/libkopete/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-08 22:39:20 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-08 22:39:20 +0200
commitd36d9267539f12fdaa5a0dd18f6285e4a636e1ac (patch)
tree65966d4e78c0529e0e56f8586a7d9c2ae530d336 /kopete/libkopete/CMakeLists.txt
parent54888da0ae983555ec963c52007c50d49b3c66af (diff)
downloadtdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.tar.gz
tdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kopete/libkopete/CMakeLists.txt')
-rw-r--r--kopete/libkopete/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/kopete/libkopete/CMakeLists.txt b/kopete/libkopete/CMakeLists.txt
index 7c1130ea..46c9e6ef 100644
--- a/kopete/libkopete/CMakeLists.txt
+++ b/kopete/libkopete/CMakeLists.txt
@@ -57,7 +57,12 @@ install( FILES
install( FILES kopete.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
install( FILES kopetecommandui.rc DESTINATION ${DATA_INSTALL_DIR}/kopete )
-install( FILES kopeteplugin.desktop kopeteprotocol.desktop kopeteui.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+
+tde_create_translated_desktop(
+ SOURCE kopeteplugin.desktop kopeteprotocol.desktop kopeteui.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR kopete-desktops
+)
##### kopete (shared) ###########################