summaryrefslogtreecommitdiffstats
path: root/kopete/libkopete/tests/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:46 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:46 -0600
commit48087e1d5650499b6093a6816356d467c8461802 (patch)
tree00c39f978492596620df1374e8a91af507d8bac3 /kopete/libkopete/tests/Makefile.am
parentccfaeb9b831a41e93e777b041cdf33a7d40a0e0b (diff)
downloadtdenetwork-48087e1d5650499b6093a6816356d467c8461802.tar.gz
tdenetwork-48087e1d5650499b6093a6816356d467c8461802.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'kopete/libkopete/tests/Makefile.am')
-rw-r--r--kopete/libkopete/tests/Makefile.am32
1 files changed, 16 insertions, 16 deletions
diff --git a/kopete/libkopete/tests/Makefile.am b/kopete/libkopete/tests/Makefile.am
index 417ce2a8..3bb06d3d 100644
--- a/kopete/libkopete/tests/Makefile.am
+++ b/kopete/libkopete/tests/Makefile.am
@@ -3,22 +3,22 @@ AM_CPPFLAGS = -DKDE_NO_COMPAT -DQT_NO_ASCII_CAST -DQT_NO_COMPAT \
$(KOPETE_INCLUDES) -I$(top_srcdir)/kopete/libkopete/private -I$(top_srcdir)/kopete/libkopete/private -I$(top_srcdir)/kopete/libkopete/tests/mock $(all_includes) -DSRCDIR=\"$(top_srcdir)/kopete/libkopete/tests\"
METASOURCES = AUTO
-check_LTLIBRARIES = kunittest_kopetemessage_test.la kunittest_kopetepropertiestest.la kunittest_kopetecontactlist_test.la
-noinst_LTLIBRARIES = kunittest_kopeteemoticontest.la
+check_LTLIBRARIES = tdeunittest_kopetemessage_test.la tdeunittest_kopetepropertiestest.la tdeunittest_kopetecontactlist_test.la
+noinst_LTLIBRARIES = tdeunittest_kopeteemoticontest.la
check_PROGRAMS = kopetewallettest_program kopetepasswordtest_program
-kunittest_kopetepropertiestest_la_SOURCES = kopetepropertiestest.cpp ../kopeteproperties.cpp
-kunittest_kopetepropertiestest_la_LIBADD = -lkunittest ../libkopete.la
-kunittest_kopetepropertiestest_la_LDFLAGS = -module $(KDE_CHECK_PLUGIN) $(all_libraries)
+tdeunittest_kopetepropertiestest_la_SOURCES = kopetepropertiestest.cpp ../kopeteproperties.cpp
+tdeunittest_kopetepropertiestest_la_LIBADD = -ltdeunittest ../libkopete.la
+tdeunittest_kopetepropertiestest_la_LDFLAGS = -module $(KDE_CHECK_PLUGIN) $(all_libraries)
-kunittest_kopeteemoticontest_la_SOURCES = kopeteemoticontest.cpp
-kunittest_kopeteemoticontest_la_LIBADD = -lkunittest ../libkopete.la
-kunittest_kopeteemoticontest_la_LDFLAGS = -module $(KDE_CHECK_PLUGIN) $(all_libraries)
+tdeunittest_kopeteemoticontest_la_SOURCES = kopeteemoticontest.cpp
+tdeunittest_kopeteemoticontest_la_LIBADD = -ltdeunittest ../libkopete.la
+tdeunittest_kopeteemoticontest_la_LDFLAGS = -module $(KDE_CHECK_PLUGIN) $(all_libraries)
-kunittest_kopetemessage_test_la_SOURCES = kopetemessage_test.cpp
-kunittest_kopetemessage_test_la_LIBADD = -lkunittest mock/libkopete_mock.la
-kunittest_kopetemessage_test_la_LDFLAGS = -module $(KDE_CHECK_PLUGIN) $(all_libraries)
+tdeunittest_kopetemessage_test_la_SOURCES = kopetemessage_test.cpp
+tdeunittest_kopetemessage_test_la_LIBADD = -ltdeunittest mock/libkopete_mock.la
+tdeunittest_kopetemessage_test_la_LDFLAGS = -module $(KDE_CHECK_PLUGIN) $(all_libraries)
kopetewallettest_program_SOURCES = kopetewallettest_program.cpp
kopetewallettest_program_LDFLAGS = -no-undefined $(all_libraries) $(KDE_RPATH)
@@ -28,14 +28,14 @@ kopetepasswordtest_program_SOURCES = kopetepasswordtest_program.cpp
kopetepasswordtest_program_LDFLAGS = -no-undefined $(all_libraries) $(KDE_RPATH)
kopetepasswordtest_program_LDADD = ../libkopete.la
-kunittest_kopetecontactlist_test_la_SOURCES = kopetecontactlist_test.cpp
-kunittest_kopetecontactlist_test_la_LIBADD = -lkunittest mock/libkopete_mock.la
-kunittest_kopetecontactlist_test_la_LDFLAGS = -module $(KDE_CHECK_PLUGIN) $(all_libraries)
+tdeunittest_kopetecontactlist_test_la_SOURCES = kopetecontactlist_test.cpp
+tdeunittest_kopetecontactlist_test_la_LIBADD = -ltdeunittest mock/libkopete_mock.la
+tdeunittest_kopetecontactlist_test_la_LDFLAGS = -module $(KDE_CHECK_PLUGIN) $(all_libraries)
noinst_HEADERS = kopetepropertiestest.h kopeteemoticontest.h
check-local:
- kunittestmodrunner
+ tdeunittestmodrunner
guicheck:
- kunittestmod $(PWD)
+ tdeunittestmod $(PWD)